Posts by Brick

    I have the following in my config-


    The top one opens the hostname in a tab

    The second one opens the nagios server backend and opens the status page for that host


    The second one works fine, it populates the macros correctly and the link works fine-


    https://nagios.domain.com/nagi…tus.php?host=thisserver01


    The top one however doesn't populate the macros, it generates this URL-


    https://%24hostname%24.domain.com


    I can even see when I hover over the link that it goes direct to the text on the top one but runs the second one though status.cgi with replacemacros


    Am I missing something?

    Thruk 2.14 on RHEL 7.2


    I have setup my SSL cert which is working fine


    I have set use_ssl_authentication to 'yes' in the config


    But when I try to log into the https:// address of the thruk server I get this-


    You are not authorized.

    It seems like you are not authorized.





    (It doesn't even show a login screen)

    Running Thruk 2.14 on RHEL 7.2


    My reports are currently not displaying any item which has an action menu attached to it-


    This is the results of my report-




    But this is the result of cutting and pasting the 'report from url' into the browser-




    The only server that shows up in the report is the one without the action menu- I have tested it several times with different servers but it is always the ones with the action menu items that don't show up


    I had a quick search though the html in the report to see if it just wasn't showing up correctly but there is no reference to those servers in there

    Ok, I have disabled JavaScript on these reports, they are rendering fine now- but when I try to email them out I get an error-


    FYI All of my reports are now failing with the same message, here are the URL's-


    /thruk/cgi-bin/status.cgi?nav=&entries=all&hidesearch=0&hidetop=&dfl_columns=&dfl_s0_hoststatustypes=2&dfl_s0_servicestatustypes=20&dfl_s0_hostprops=0&dfl_s0_serviceprops=8202&style=detail&dfl_s0_serviceprop=2&dfl_s0_serviceprop=8&dfl_s0_serviceprop=8192&dfl_s0_type=service&dfl_s0_val_pre=&dfl_s0_op=~&dfl_s0_value=disk+usage&dfl_s0_value_sel=5&sortoption=3&sorttype=2


    /thruk/cgi-bin/status.cgi?dfl_s0_value_sel=5&dfl_s0_servicestatustypes=31&dfl_s0_op=%3D&dfl_s0_val_pre=&dfl_s0_serviceprop=2&dfl_s0_serviceprop=4&hidesearch=2&dfl_s0_hostprops=0&style=detail&dfl_columns=host_name%2Cdescription%2Cstate%2Clast_check%2Cduration%2Ccurrent_attempt%2Cpeer_name%2Cplugin_output%2Ccomments&dfl_s0_serviceprops=6&dfl_s0_type=host&hidetop=&dfl_s0_hoststatustypes=15&dfl_s0_value=all&page=1&entries=all&total_pages=10


    /thruk/cgi-bin/status.cgi?hidesearch=2&hidetop=&dfl_s0_hoststatustypes=15&dfl_s0_servicestatustypes=20&dfl_s0_hostprops=0&dfl_s0_serviceprops=8224&style=detail&dfl_s0_serviceprop=32&dfl_s0_serviceprop=8192&dfl_s0_type=service&dfl_s0_val_pre=&dfl_s0_op=~&dfl_s0_value=System%20-%20Uptime&dfl_s0_value_sel=5&sortoption=9&sorttype=1

    I have just upgraded to 2.14-

    Code
    1. [root@~]# yum list | grep thruk
    2. libthruk.x86_64 2.14-1.el7.centos @labs_consol_stable
    3. thruk.x86_64 2.14-1 @labs_consol_stable
    4. thruk-base.x86_64 2.14-1 @labs_consol_stable
    5. thruk-plugin-reporting.x86_64 2.14-1 @labs_consol_stable
    6. naemon-thruk.x86_64 1.0.6-1.el7.centos labs_consol_stable


    When I create a new report from URL I get the following error while trying to render it-


    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2261 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2277 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2627 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2642 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2672 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2687 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2717 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2734 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2764 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2779 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2809 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2824 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2854 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:2869 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:3495 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:3510 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:3540 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:3555 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:3599 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:3643 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:3687 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:3731 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:3775 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:3805 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:3849 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:4046 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:4090 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:4134 in global code
    ReferenceError: Can't find variable: print_action_menu



    file:///var/lib/thruk/reports/8.html:4178 in global code

    I am unable to get Thruk 2.12-3 working with Active Directory users.


    I added the below to /etc/httpd/conf.d/thruk.conf and restarted Thruk (edited for my site)-



    I now get the below when trying to authenticate:


    authorization failed for user myuser got rc 401authorization failed for user myuser got rc 401[Thu Feb 09 18:46:56.266445 2017] [auth_basic:error] [pid 15702] [client 127.0.0.1:39874] AH01618: user myuser not found: /thruk/cgi-bin/restricted.cgi


    Have I missed a step here? Can you just summarize the steps involved please.

    Using -

    Thruk Version 2.12-3

    Redhat 7.2


    Whenever I click on 'Create E-Mail Report for this Page' it only populates the 'Report from Url' field with-


    /thruk/cgi-bin/status.cgi


    The URL for the page I am on when I am clicking the button is-


    /thruk/#cgi-bin/status.cgi?hidesearch=2&hidetop=&dfl_s0_hoststatustypes=15&dfl_s0_servicestatustypes=20&dfl_s0_hostprops=0&dfl_s0_serviceprops=8224&style=detail&dfl_s0_serviceprop=32&dfl_s0_serviceprop=8192&dfl_s0_type=service&dfl_s0_val_pre=&dfl_s0_op=~&dfl_s0_value=System%20-%20Uptime&dfl_s0_value_sel=5&sortoption=9&sorttype=1


    Even if I go in and edit the report and put this full url in the report that is sent out is still the one created by '/thruk/cgi-bin/status.cgi'


    Any Ideas whats going wrong?

    I am running Nagios 5.3.1 on RHEL 7

    Trying to get livestatus installed so I can use Thruk

    Has anyone successfully done this? I have tried the last stable 1.2.8 but when I install it scrambles the nagios service