Posts by urgen-sherpa

    On browsers when i visit an ASPx site i get 200 response but when i wanted to monitor it through icinga2 http_check with ssl on i get below output on PLUGIN Output :
    HTTP WARNING: HTTP/1.1 400 Bad Request - 513 bytes in 0.232 second response time
    similary with curl command too where this site gives 500 on curl but on browser its 200 OK
    Example site: curl -I https://login.xero.com
    HTTP/1.1 503 Service Unavailable


    Below is my host file


    Object Host "secure.example.com" {
    address = "10.23.81.22"
    check_command = "http"
    vars.http_vhosts["secure.example.com"] = {
    http_uri = "/user/login.aspx"
    }
    vars.http_ssl="1"
    vars.notification["mail"] = {
    groups = [ "icingaadmins" ]
    }
    }


    Thanks

    i have setup iciinga r2.5.4-1 on ubuntu 16.04 LTS
    currently im getting strange notifications email which looks like below



    ***** Icinga *****
    Notification Type: DOWNTIMESTART
    Service: load
    Host: icinga2.example.com
    Address: 127.0.0.1
    State: OK
    Date/Time: 2016-11-29 02:00:37 +0000
    Additional Info: OK - load average: 0.02, 0.02, 0.00
    Comment: [icingaadmin] Scheduled downtime for backup




    The server is up since 4-5 days(not restarted) and Im sure i have not scheduled any downtimes or backup, . Does any one happen to know where do i look and change so that this notification is stopped.

    I have just installed thruk on same centos7 box(with icinga 1.10 running) using labs_consol_stable yum repository and installed mk-livestatus from
    source, and configure broker_module as broker_module=/usr/local/lib/mk-livestatus/livestatus.o /etc/icinga/live


    I also setup the xinetd to listen to 6557 but when i go to /thruk url it shows "You are not authorized. It seems like you are not authorized." error message directly without authentication form.