Naemon /Thruk - Default-User

  • Hallo Community,


    gleich in meinem ersten Beitrag komme ich mit einer Frage - Asche auf mein Haupt - aber ich bin verzweifelt
    Bisher habe ich mit Nagios 3 meine Systeme überwacht, mich nun aber entschlossen auf Naemon umzusteigen. Im Großen und Ganzen hat das auch super funktioniert, wenn da nicht ein kleines Problem wäre.
    Ich habe meinen Administratoren bisher die Möglichkeit gegeben als Default-User aufs Nagios-Front-End zuzugreifen, ohne sich extra einloggen zu müssen. Realisiert hatte ich das, indem ich in der CGI.cfg einen Default-User festlegte
    und in der Nagios.cfg des Apache die Authentication-Direktiven angepasst habe.
    Bei Naemon mit Thruk will mir das aber nicht so recht gelingen. Zwar habe ich auch hier in der CGI.cfg einen Default-User festgelegt, mit der Thruk.cfg im Apache komme ich aber überhaupt nicht zurecht, da mir dazu leider das Tiefenwissen zum Apache fehlt.
    Im Gegensatz zu Nagios werden etwa bei Naemon offensichtlich die CGI-Files live generiert, da ich sie auf dem System (SLES11SP3) nicht finden kann. So weiß ich aber nicht, was ich nun wie authentifizieren kann, um direkt als Standard-User ohne manuelles Login aufs Front-End zugreifen zu können. Nachdem ich nun seit Wochen nicht richtig vorwärts komme, hoffe ich nun auf die Schwarmintelligenz dieses Forums.


    Ich hoffe, ich habe mich halbwegs verständlich ausgedrückt und befinde mich hier auch im richtigen Forum.


    Vielen Dank schon mal für eure Hilfe!
    Thomas

  • Die cgi.cfg bei Thruk ist nahezu identisch mit der von Nagios. Um die Authentifizierung im Apache abzuschalten, reicht es die jeweligen Teile in der Apache Config auskommentieren. Du solltest unter /etc/apache ein Config File haben das ca. so aussieht wie das hier:
    https://github.com/sni/Thruk/b…support/apache_fcgid.conf
    Kommentiere dort Zeile 50-65 raus.
    Je nach System hast du auch noch ein include auf die thruk_cookie auth Datei in den vhosts. Den Include müsstest du auch rauswerfen.

  • Hi sni,


    ich hatte die thruk_cookie_auth-Datei nicht beachtet, das wars!
    Damit hast du mich echt ein ganzes Stück vorwärts gebracht, vielen Dank!!!
    Nun habe ich nur noch ein kleines Problemchen, aber da teste ich erst mal ein bisschen rum ;)


    Danke noch mal!