(Solved) Can't locate utils.pm in @NIC -> verweis auf einen falschen Pfad

Please read about the latest changes and upgrade.
Please note that your newly registered account needs to be manually activated by an admin. Just be patient, you cannot post to any forum before this happens. This is thanks to the unfortunate event of spammers recently. More details here.
  • Hallo Ihr Leutz!


    Ich habe mich heute mal daran gesetzt, unser Überwachungssystem von NAGIOS auf ICINGA umzusetzen (Neuinstalltion auf dem frischen System) da dies vielversprechender ist Nagios ;-)
    Ps: Habe aber noch nicht meine Profildaten umgesetzt bis es fehlerfrei läuft!
    IcingaCore 1.2.1
    Nagios-Plugins 1.4.15


    Die Installation und Konfiguration verlief problemlos bis zum ersten Test.
    Ich wollte auf dem lokalen Icinga-Server mittels den ServerAgent & check_fsc_systemhealth_plugin die Funktion testen und hier tritt der erste Fehler auf.


    Folgende Meldung erhalte Ich:
    Can't locate utils.pm in @INC (@INC contains: /usr/local/nagios/libexec ..................
    Woran kann das liegen, dass hier nicht im Verzeichnis /usr/local/icinga/libexec gesucht wird wo auch die entsprechende Datei liegt ?


    Bei der Installation der NagiosPlugins habe ich auch meines Erachtens die richtigen Parabel angegeben
    ./configure \
    --sysconfdir=/etc/icinga \
    --prefix=/usr/local/icinga \
    --with-nagios-user=icinga \
    --localstatedir=/var/icinga \
    --enable-perl-modules \
    --with-perlcache \
    --with-cgiurl=/icinga/cgi-bin \
    --with-htmurl=/icinga



    Ich hoffe es hat jemand einen Tip wie ich dieses Problemchen lösen könnte -----------> Danke schonmal vorab

  • wenn das die dinger von hier sind - http://www.nagios-portal.org/wbb/index.php?page=Thread&threadID=5653&pageNo=1
    dann sind dort die pfade alle hardcoded in den perl scripts.


    aendere in check_systemhealth_fsc


    Code
    1. use lib "/usr/local/nagios/libexec";


    in


    Code
    1. use lib "/usr/local/icinga/libexec";


    und probiers nochmal. dort sollte dann auch die utils.pm rumgurken. behelfsweise kannst du mit softlinks arbeiten, aber saubere plugins sind besser ;-)

  • Danke für den Hinweis und wie es der Zufall will habe ich in das Plugin auch schon mal reingeschaut aber den Wald vor lauter Bäumen nicht gesehen :rolleyes:


    Habe es jetzt für die anderen Plugins von "cookie" auch umgesetzt und siehe da -> es läuft einwandfrei


    Thanx dnsmichi