mzac Trainee

  • Member since Mar 17th 2017
  • Last Activity:
Posts
19
Points
120
Profile Hits
18
  • mzac

    Replied to the thread MySQL database tuning.
    Post
    Yes, sorry it is MariaDB that I'm running:

    mysql Ver 15.1 Distrib 5.5.52-MariaDB, for Linux (x86_64) using readline 5.1

    And I've run already the mysqltuner and tweaked as much as it recomended. I'm also graphing my sql database performance with…
  • mzac

    Post
    Sounds good, for sure I will look into that, however when I run it without the Icinga POST/PUT api calls the scripts take a few seconds to run each so I don't think my code has any bottlenecks.

    I guess having faster access to the API could be better...…
  • mzac

    Post
    Yep, that makes sense for sure!!!

    I was asking as I was re-vamping my CMDB->Icinga API scripts today and thought this could be a big time saver.

    I was able to cut my script execution time in half by doing the following:

    Original script:
    -> Query SQL
  • mzac

    Replied to the thread MySQL database tuning.
    Post
    The mysql database is running on the same host as the Icinga server itself. I still haven't got a cluster setup yet in any way or form, so everything runs on the same machine.

    As for the storage of the database, it is running on 15k SAS drives on a…
  • mzac

    Thread
    Is it possible to create multiple objects (ex hosts) in a single rest call?

    For example, my script is pulling data from a SQL database and I want to push this into Icinga via the API however for now it seems I have to make connections to the API for…
  • mzac

    Replied to the thread MySQL database tuning.
    Post
    I will be updating soon to 2.7.0, in our server environment packages are on a release cycle and I cannot influence that (not the same department) so I'll have to wait a few weeks before they let me install 2.7.0 or 2.7.1 by that time.

    Thanks
  • mzac

    Posted the thread MySQL database tuning.
    Thread
    Does anyone have any good suggestions for MySQL tuning in my setup? Whenever I do a reload it takes a few minutes to flush the queue to the database. I'm guessing this could be due to a memory leak issue that has been mentioned before in Memory leak in